Fink

P.M.F. - 7. Compile Problems - Specific Packages

P.7.1: A Falla la compilación de un paquete con errores involucrando a sed.

R.: This can happen if your login script (e.g. ~/.cshrc) does something that writes to the terminal, e.g "echo Hello" or xttitle. To get rid of the problem, the easy solution is to comment out the offending lines.

If you want to keep the echo, then you can do something like the following:

if ( $?prompt) then 
	echo Hello 
endif

P.7.2: Quiero cambiarme a los paquetes XFree86 de Fink, pero no puedo instalar xfree86-base - xfree86, porque existe un conflicto con system-xfree86.

R.: All flavors of X11, unfortunately, really needs to be installed in /usr/X11R6. Because of this the Fink xfree86-base and xfree86-rootless packages install there, too. However, since Fink won't remove any files that aren't in its database, it won't automatically replace a non-Fink installation of X11.

Here's how to proceed:

Note: 10.2.x users with up-to-date versions of Fink (>= 0.16.2) and 10.3.x users should skip step 1 below (it won't work anyway).

1. Remove system-xfree86. If you don't have any packages that depend on X11, this is straightforward. Frequently, however, many packages that depend on X11 are installed. Rather than uninstalling all of them, you can use

sudo dpkg --remove --force-depends system-xfree86

to remove it, leaving everything in place. If you don't have system-xfree86 installed then proceed to step 3.

2. Manually remove all of XFree86. This can be done with

sudo rm -rf /Applications/XDarwin.app /usr/X11R6 /etc/X11

If you are switching from Apple X11, remove the X11 application, too.

3. To get XFree86-4.2.1, Install Fink's xfree86-base and xfree86-rootless packages by the usual means: "fink install" for source users, "apt-get install" or dselect for binaries.

-or-

3a. To get XFree86-4.3.x, install Fink's xfree86 package, with "fink install xfree86"--this version isn't in the binary distro yet, and is currently only in the unstable tree [FAQ 3.9].

P.7.3: ¿Cómo puedo cambiar de la version non-threaded del paquete XFree86 de Fink a la version threaded (o viceversa)?

R.: If you are running the Fink version of XFree86 and you want to switch between the threaded and non-threaded versions of Fink, you need to manually remove the old version. This is done at the command-line with the commands:

sudo dpkg -r --force-depends xfree86-base 
sudo dpkg -r --force-depends xfree86-shlibs 
sudo dpkg -r --force-depends xfree86-rootless 
sudo dpkg -r --force-depends xfree86-rootless-shlibs

or to delete the threaded versions:

sudo dpkg -r --force-depends xfree86-base-threaded 
sudo dpkg -r --force-depends xfree86-shlibs-threaded 
sudo dpkg -r --force-depends xfree86-rootless-threaded 
sudo dpkg -r --force-depends xfree86-rootless-threaded-shlibs

FinkCommander also has a way to remove packages. In the source window, select a package, and then in the Source Menu use "Force Remove."

If you are using system-xfree86, see the previous question for removing it.

Install the version of xfree86 you want:

xfree86-base and xfree86-rootless

xfree86-base-threaded and xfree86-rootless-threaded

by the usual means: "fink install" for source users, "apt-get install" or dselect for binaries.

P.7.4: ¿Cuando intento instalar KDE, me sale el siguiente mensaje: 'Can't resolve dependency "cctools (>= 446-1)"'

R.: This somewhat cryptic message means you need to install the December 2002 Developer Tools.

P.7.5: I can't update libiconv.

R.: If you get errors of the form:

libtool: link: cannot find the library `/sw/lib/libiconv.la'

you can solve this problem by running

fink remove gettext-dev
fink install libiconv

P.7.6: i can't install a package because c++filt is missing. Where do I get it?

R.: If you get errors of the form

xgcc: installation problem, cannot exec `c++filt': No such file or directory

since updating to Tiger, then you need to do the following:

  • Reinstall BSD.pkg (from your installation media). If /usr/bin/c++filt doesn't appear, keep trying.

You also might also need to make sure you don't have any ancient Developer/Xcode Tools stuff laying around:

  • 10.4: Flush out your old Xcode Tools versions via running /Developer/Tools/uninstall-devtools.pl in a terminal. Then (re)install XCode (2.4.1 or later).
  • 10.5: Flush out your old Xcode Tools versions via running /Developer/Library/uninstall-devtools in a terminal. Then (re)install Xcode (3.0 or later).

1) Flush out your old 2) Reinstall BSD.pkg (from your main OS install)

P.7.7: Fink refuses to update the gettext package, complaining that the dependencies are in an inconsistent state.

R.: After running fink selfupdate to be sure you have the latest versions, try fink update gettext-tools. An old version of the gettext-tools package may be preventing you from updating gettext.

P.7.8: I can't install gtk+2 on OS 10.5

R.: Typically this involves missing libraries, such as: /usr/X11/lib/libXrandr.2.0.0.dylib or /usr/X11/lib/libXdamage.1.1.0.dylib (or other versions of libraries in /usr/X11/lib/).

The current wisdom on the best fix for such an issue is to install Xcode 3.1.3 or later.

P.7.9: I'm having issues with a package that isn't listed here.

R.: Since package problems tend to be transient, we've decided to put them up on the Fink wiki. Check the Package issues page.

Siguiente: 8. Package Usage Problems - General